re = /(?<!\S)Bob[\s._-]1(?![^\s._-])/
str = 'Hello, I\'m Bob 1 --> Should capture Bob 1
Hello, I\'m Bob 11 --> Should capture nothing (Bob 1 is not at the end or followed by a separator)
Hey, it\'s Bob-1 over there --> Should capture Bob-1
Hey, it\'s Bob - 1 over there --> Should capture nothing (Bob should be followed only by one separator not 3 like here)
Bob.1 --> Should capture Bob.1
Bob_1 rules! --> Should capture Bob_1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end