#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^"]*'(.*)$"
Local $sString = "Working - This is a test 'This should be captured" & @CRLF & _
"Working - "this is a test" 'This should be captured" & @CRLF & _
"Not Working - "this is a test" 'This should be "captured"" & @CRLF & _
"Not Working - This is a test 'This should be "captured"" & @CRLF & _
"Working - "this is a test 'this should not capture'" 'this should capture" & @CRLF & _
"Working - "this isn't a test" 'this should capture" & @CRLF & _
"And "this"? Does it "work" or doesn't it? ' Comment" & @CRLF & _
""Having ""quoted"" quotes couldn't work, could they"? "Yeah, they do!" ' Great"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")