# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^\"'\n]*(?:\"(?:[^\"\n]|\"\")*\"))*[^\"]*'(.*)$"
test_str = ("Working - This is a test 'This should be captured\n"
"Working - \"this is a test\" 'This should be captured\n"
"Not Working - \"this is a test\" 'This should be \"captured\"\n"
"Not Working - This is a test 'This should be \"captured\"\n"
"Working - \"this is a test 'this should not capture'\" 'this should capture\n"
"Working - \"this isn't a test\" 'this should capture\n"
"And \"this\"? Does it \"work\" or doesn't it? ' Comment\n"
"\"Having \"\"quoted\"\" quotes couldn't work, could they\"? \"Yeah, they do!\" ' Great")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.