#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^']*('(?:_\n|.)*)"
Local $sString = "ewr "Having ""quoted"" quotes couldn't work, could they"? "Yeah, they do!" 'Great" & @CRLF & _
"Working - This is a test 'This should be captured" & @CRLF & _
"Working - "this is a test" 'This should be captured" & @CRLF & _
"Not Working - "this is a test" 'This should be "captured"" & @CRLF & _
"Not Working - This is a test 'This should be "captured"" & @CRLF & _
"Working - "this is a test 'this should not capture'" 'this should capture" & @CRLF & _
"Working - "this isn't a test" 'this should capture" & @CRLF & _
"'Comment with a line _" & @CRLF & _
"continuation" & @CRLF & _
"Debug.Print 'End of line comment _" & @CRLF & _
"with line continuation." & @CRLF & _
"Debug.Print 42 'The next line... _" & @CRLF & _
""...is not a string literal"" & @CRLF & _
"Debug.Print "Unmatched double quotes." 'Comment"" & @CRLF & _
"Debug.Print "Interleaved single 'n double quotes." 'Comment"" & @CRLF & _
"'No comments or strings in the line below." & @CRLF & _
"Debug.Print [Evil:""Comment"'here]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")