use strict;
my $str = 'ewr "Having ""quoted"" quotes couldn\'t work, could they"? "Yeah, they do!" \'Great
Working - This is a test \'This should be captured
Working - "this is a test" \'This should be captured
Not Working - "this is a test" \'This should be "captured"
Not Working - This is a test \'This should be "captured"
Working - "this is a test \'this should not capture\'" \'this should capture
Working - "this isn\'t a test" \'this should capture
\'Comment with a line _
continuation
Debug.Print \'End of line comment _
with line continuation.
Debug.Print 42 \'The next line... _
"...is not a string literal"
Debug.Print "Unmatched double quotes." \'Comment"
Debug.Print "Interleaved single \'n double quotes." \'Comment"
\'No comments or strings in the line below.
Debug.Print [Evil:""Comment"\'here]
';
my $regex = qr/^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^']*('(?:_\n|.)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}