$re = '/^((?!0)(\d{1,5}))$/m';
$str = '87347
124
1
0
848/\'A$
949A4
000
0132183792
4A874';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);