#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})"
Local $sString = "29.08.11" & @CRLF & _
"19.08.2011" & @CRLF & _
"" & @CRLF & _
"1.1.12" & @CRLF & _
"01.1.12" & @CRLF & _
"1.01.12" & @CRLF & _
"1.1.2021" & @CRLF & _
"01.1.2012" & @CRLF & _
"1.01.2012" & @CRLF & _
"" & @CRLF & _
"1:1:1" & @CRLF & _
"01:1:1" & @CRLF & _
"1:01:1" & @CRLF & _
"1:1:01" & @CRLF & _
"01:01:01" & @CRLF & _
"1:12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")