const regex = /(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}\\.\\d{1,2}\\.\\d{2,4})|(\\d{1,2}\\:\\d{1,2}\\:\\d{1,2})|(\\d{1,2}\\:\\d{1,2})', 'gm')
const str = `29.08.11
19.08.2011
1.1.12
01.1.12
1.01.12
1.1.2021
01.1.2012
1.01.2012
1:1:1
01:1:1
1:01:1
1:1:01
01:01:01
1:12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}