package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B[a-zA-Z'-]+|\W+`)
var str = `MY HOSPITAL'S NAME`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}