const regex = /\B[a-zA-Z'-]+|\W+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B[a-zA-Z\'-]+|\\W+', 'gm')
const str = `MY HOSPITAL'S NAME`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);