package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[(?P<datetime>.+)\]\[(?P<thread>[^\]]+)\])?(?P<subsystem>.+?):\s*((?P<level>Fatal|Error|Warning|Log):\s?)?(?P<msg>.+)`)
var str = `[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}