# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Diagnostic-Code:\s+?(.*)"
test_str = ("Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does\n"
" not exist. Please try 550-5.1.1 double-checking the recipient's email\n"
" address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1\n"
" https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp")
matches = re.search(regex, test_str, re.IGNORECASE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.