const regex = /^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[+?0?0?966]+)(?:\\s?\\d{2})(?:\\s?\\d{7}))$', 'gm')
const str = `+966533333333
+966 53 3333333
??????????? 000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}