re = /^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$/m
str = '+966533333333
+966 53 3333333
??????????? 000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end