re = /\/var\/log\/nginx\/access\_(?<string>\S+)\.log/m
str = '/var/log/nginx/access_api-developer-dev.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end