#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(https:\/\/)(\S*)(gmail-getter)([\w\/\?\=\-]*)"
Local $sString = "<a href="https://github.com/bormando/gmail-getter" style="background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk">GitHub" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")