import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/)(\\S*)(gmail-getter)([\\w\\/\\?\\=\\-]*)";
final String string = "<a href=\"https://github.com/bormando/gmail-getter\" style=\"background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk\">GitHub\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}