re = /(\bdog\w*)|(\w*cat\b)/m
str = 'dog cat catdog dogcat 1dog file.dog dog.cat dog-cat banana bananacat dogapple-bananacat dog32 123cat dog12cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end