package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s{2,}\W+(\d+(?:\.\d+)?)`)
var str = `CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}