const regex = new RegExp('(?<=^|"",)""|""(?=,""|$)', 'gmi')
const str = `"foo","bar"
"baz","qu""ux"
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);