use strict;
my $str = '"foo","bar"
"baz","qu""ux"
';
my $regex = qr/(?<=^|"",)""|""(?=,""|$)/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";