using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$";
string input = @"http://mysite.com/contact
http://mysite.com/index.cfm?p=contact
http://mysite.com/contact.cfm
http://mysite.com/ajax/contact-form.cfm
http://mysite.com/index.cfm?p=contact.cfm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}