use strict;
my $str = 'http://mysite.com/contact
http://mysite.com/index.cfm?p=contact
http://mysite.com/contact.cfm
http://mysite.com/ajax/contact-form.cfm
http://mysite.com/index.cfm?p=contact.cfm
';
my $regex = qr/^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}