using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<section(.*\s)<\/section>";
string input = @"<section class=""ui grid topbar"">une ligne</section>
<section class=""ui grid topbar"">
<div class=""ui row"">
... des divs etc
</div>
</section>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}