package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<section(.*\s)<\/section>`)
var str = `<section class="ui grid topbar">une ligne</section>
<section class="ui grid topbar">
<div class="ui row">
... des divs etc
</div>
</section>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}