const regex = /<section(.*\s)<\/section>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<section(.*\\s)<\\\/section>', '')
const str = `<section class="ui grid topbar">une ligne</section>
<section class="ui grid topbar">
<div class="ui row">
... des divs etc
</div>
</section>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}