$re = '/<section(.*\s)<\/section>/';
$str = '<section class="ui grid topbar">une ligne</section>
<section class="ui grid topbar">
<div class="ui row">
... des divs etc
</div>
</section>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);