$re = '/^([a-z\d\.-_-]+)@([a-z\d-]+)([\.])([a-z]{2,6})(\.[a-z]{2,6})?$/m';
$str = 'super_cool-email.address@must-match-fully.com
super_cool-email.address@must-match-fully.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);