$re = '/absoluteText_(\d+)\([^,]+,\s*(.*?)\)/m';
$str = 'absoluteText_12(A, B, C)';
$subst = "absoluteText_$1($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;