# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\A[\s\S]*\S\K\s*\z//g;t' <<< "Linkin Park.png
Rammstein.png
Metallica.png
Guns N' Roses.png
"