#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\A[\s\S]*\S\K\s*\z"
Local $sString = "Linkin Park.png" & @CRLF & _
"Rammstein.png" & @CRLF & _
"Metallica.png" & @CRLF & _
"Guns N' Roses.png" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)