use strict;
my $str = 'Linkin Park.png
Rammstein.png
Metallica.png
Guns N\' Roses.png
';
my $regex = qr/\A[\s\S]*\S\K\s*\z/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";