import Foundation
let pattern = #"\A[\s\S]*\S\K\s*\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Linkin Park.png
Rammstein.png
Metallica.png
Guns N' Roses.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)