package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n`)
var str = `Linkin Park
Rammstein
Metallica
Guns N' Roses`
var substitution = "|"
fmt.Println(re.ReplaceAllString(str, substitution))
}