#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:JQ1|mock)_(?:BRD4|input)_(?:A|B))"
Local $sString = "DNA160630JA_JQ1_BRD4_A_S4_L001_R1_001.fastq" & @CRLF & _
"DNA160630JA_JQ1_BRD4_B_S8_L002_R1_001.fastq" & @CRLF & _
"DNA160630JA_JQ1_input_A_S3_L001_R1_001.fastq" & @CRLF & _
"DNA160630JA_JQ1_input_B_S7_L002_R1_001.fastq" & @CRLF & _
"DNA160630JA_mock_BRD4_A_S2_L001_R1_001.fastq" & @CRLF & _
"DNA160630JA_mock_BRD4_B_S6_L002_R1_001.fastq" & @CRLF & _
"DNA160630JA_mock_input_A_S1_L001_R1_001.fastq" & @CRLF & _
"DNA160630JA_mock_input_B_S5_L002_R1_001.fastq"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")