# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:JQ1|mock)_(?:BRD4|input)_(?:A|B))"
test_str = ("DNA160630JA_JQ1_BRD4_A_S4_L001_R1_001.fastq\n"
"DNA160630JA_JQ1_BRD4_B_S8_L002_R1_001.fastq\n"
"DNA160630JA_JQ1_input_A_S3_L001_R1_001.fastq\n"
"DNA160630JA_JQ1_input_B_S7_L002_R1_001.fastq\n"
"DNA160630JA_mock_BRD4_A_S2_L001_R1_001.fastq\n"
"DNA160630JA_mock_BRD4_B_S6_L002_R1_001.fastq\n"
"DNA160630JA_mock_input_A_S1_L001_R1_001.fastq\n"
"DNA160630JA_mock_input_B_S5_L002_R1_001.fastq")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.