$re = '/^(?=.*[ěščřžýáíéóúůüöďťňa-z])(?=.*[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Z])(?=.*\d)(?=.*[$@#$.,_§!()%*?&+~|{}:;<>])[ĎŇŤĚŠČŘŽÝÁÍÉÖÓÚŮÜA-Zěščřžýáíéóúůüöďťňa-z\d$@#$.,_§!()%*?&+~|{}:;<>]{8,}/m';
$str = 'WebCa,r§ol1*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);