package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http|https|wss|ws|ftp|ftps):\/\/`)
var str = `http://
https://
wss://
ws://
ftp://
ftps://`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}