re = /(http|https|wss|ws|ftp|ftps):\/\//m
str = 'http://
https://
wss://
ws://
ftp://
ftps://'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end