// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?").unwrap();
let string = ".123e123
.123e+123
.123e-123
123.e123
123.e+123
123.e-123
123.123e123
123.123e+123
123.123e-123
.e1
.1e1.2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}