$re = '/^([^<>{}]|<([^<>{}]|{[^<>{}]*})*>|{([^<>{}]|<[^<>{}]*>)*})*$/m';
$str = 'XXX<XX{X}XXX>X
X{X}X<X>X{X}X<X>X
XXX<X<XX>>XX
XX<XX{XX>XX}XX
XX<XX{XX>XXXX
XX<XX{XX{XX}XX}XX>XX
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);