#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>(?!\/(?>test|abc|kimochi)\/).)+?$"
Local $sString = "https://domain.com/test/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/abc/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/kimochi/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/testa/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/sad-test-sad/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/a-abc/link" & @CRLF & _
"" & @CRLF & _
"https://domain.com/akimochi/link"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")