$re = '/^(I\d{11})R(\d{9})(\d{6})(0{3})FR(\D{1})$
/';
$str = 'I01750258411R100842207160419000FRA
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);