#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\bdetails\.cfm\b).*\bselector=size\b.*$"
Local $sString = "http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1" & @CRLF & _
"http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size" & @CRLF & _
"http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size" & @CRLF & _
"http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1" & @CRLF & _
"http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")