# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\bdetails\.cfm\b).*\bselector=size\b.*$"
test_str = ("http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1\n"
"http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size\n"
"http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size\n"
"http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1\n"
"http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.