#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.*\\\\)?(?<username>.*)"
Local $sString = "SPLUNK\\xander" & @CRLF & _
"DOMAIN\\foo" & @CRLF & _
"WORK\\reswob4" & @CRLF & _
"username" & @CRLF & _
"username" & @CRLF & _
"WORK\\username"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")