package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*\\\\)?(?<username>.*)`)
var str = `SPLUNK\\xander
DOMAIN\\foo
WORK\\reswob4
username
username
WORK\\username`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}