import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<item>.*?<id>((?:(?!<id>).)*?)</id>(?:(?!<item>).)*<img>(.*?)</img>.*?</item>";
final String string = "<set>\n"
+ "<item>\n"
+ " <id>1</id>\n"
+ " <title>title1</title>\n"
+ "</item>\n"
+ "<item>\n"
+ " <id>2</id>\n"
+ " <title>title2</title>\n"
+ "</item>\n"
+ "<item>\n"
+ " <id>3</id>\n"
+ " <title>title3</title>\n"
+ " <img>img3</img>\n"
+ "</item> \n"
+ "</set>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}