#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^((?:(?!\.)[\w\/])*?)\/?$"
Local $sString = "/someScript" & @CRLF & _
"/module/employee/anotherScript" & @CRLF & _
"/someScript/" & @CRLF & _
"/module/employee/anotherScript/"
Local $sSubst = "$1.cfm"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)