import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?!\\.)[\\w\\/])*?)\\/?$";
final String string = "/someScript\n"
+ "/module/employee/anotherScript\n"
+ "/someScript/\n"
+ "/module/employee/anotherScript/";
final String subst = "$1.cfm";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}